Showing posts with label Sharepoint 2013. Show all posts
Showing posts with label Sharepoint 2013. Show all posts

Thursday, June 23, 2016

Sharepoint 2013: “Access Denied” Error Message While Activating A Timerjob Site-Feature or Custom Web Part Feature

ULS: Access denied. w3wp.exe (0x1E30) – 6615 – Critical under /_layouts/ManageFeatures.aspx?Scope=Site
Getting a error message while activating a timerjob site-feature (on a production system with uac) as farm and local administrator on a sharepoint site.
1) Execute this powershell script as farmadmin:
function Set-AccessDenied-False()
# load sharepoint api libs
[System.Reflection.Assembly]::LoadWithPartialName(“Microsoft.SharePoint”) > $null
[System.Reflection.Assembly]::LoadWithPartialName(“Microsoft.SharePoint.Administration”) > $null# get content web service
$contentService = [Microsoft.SharePoint.Administration.SPWebService]::ContentService
# turn off remote administration security
$contentService.RemoteAdministratorAccessDenied = $false
# update the web service

2) App pool recycle or iisreset
3) Active your feature again

Friday, March 18, 2016

Sharepoint 2013 Workflow Tasks List - View with Filtered By Assigned To = Sharepoint Groups


I have workflow with three approvers, One approvers is specific person, the other approvers are two sharepoint groups like HR SP Group and CEO SP Group.

I would like to add task webpart in the home page to filter my sharepoint Workflow 2013 Tasks list only to display the tasks assigned to the current user.

Hence I create a HR View and set a filter ‘Assigned To’ is equal to [Me] in the view.

However, I am not seeing the tasks that has a HR SP Group assigned and the HR SP group contains the current user.


 Here are the steps:

  1. Create HR Task view in the Task List.
  2. set a filter ‘Assigned To’ is equal to HR SP Group in the view.
  3. Open SharePoint Designer.
  4. Open theHR Task view of the task list in code view.
  5. Find the tag and within it add the following:

Find the Tag

Replace to

     6.Save the view and open it again in the browser.

Wednesday, September 16, 2015

Enable cross domain sharepoint profile picture in sharepoint 2013

I just enabled custom claim provider Authentication in the 80 web application, After that I just enabled My Site with custom claim provider Authentication .

When I open my 80 website and click on the my site link then My Profile picture is not showing in the first time.  So I just enabled in the below solution. It is working fine.

Run the code in the PowerShell skills. Basically all you need to do is to set the CrossDomainPhotosEnabled property on the SPWebApplication object to true, like this:
asnp Microsoft.SharePoint.PowerShell
$wa = Get-SPWebApplication
$wa.CrossDomainPhotosEnabled = $true

Thursday, July 9, 2015

LDAP/AD Claims Provider For SharePoint 2013

I just configured  LDAPCP with ADFS. But I am not able to access the different domain users (abcd users) with sp site.

My configuration is:

I have Wxyz Ad Domain with Wxyz sharepoint 2013 server and have abcd domain and abcd adfs server.

Already configured ADFS server and deployed LDAPCP WSP(codeplaex) solution successfully,added LDAP connection in security on SP central Admin.

The people picker is retreiving abcd user name john and added in the sp site.

Issues occured:

when I am trying to access the Sharepoint site with abcd domain user's(john) on the AD FS server. It is showing in the below error

Error displaying:

Sharepoint Site Error:

Sorry, this site hasn't been shared with you.

Event viewer Error:

A Certificate validation operation took 15019.4231 milliseconds and has executed the execution time threshold.
If this continues to occur, it may represent a configuration issue.


Identifier Claim should be email address in the powershell script and set claim mapping should be Samsaccountname  = emailaddress on the AD FS server

Add ABCD user login id in the sharepoint sites and try to access the sp pages from AD FS Servers using cliam based authentication.

Finally we logged in successfully for ABCD users on the Sharepoint Sites.

Tuesday, November 18, 2014

Create first sharepoint 2013 App,Develop and Deploy on the sharepoint server

Add DNS Server via server Role


Get IP Address

Add New Domain for App like

Add wildcards

Add Host entry on the drive\etc\host

GO to central Admin and configure App URL

Login as spsfarm not as System Admin account and Open Visual studio shift + Right Click with different user (login as spsfarm) on the visual studio solution file

If deployment is restricted for administrator privileges then Login with windows as spsfarm than you can deployed

Once deployed you can see the app in the SharePoint sites

If you click on the app that content won’t display and it is asking three times for credentials

Disable Loop Back Check

In HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa, create a DWORD for DisableLoopbackCheck and enter a value of “1” (hexadecimal).

Note: I Just created DisableLoopBackCheck ,it was throw error, so this case sensitive

Follow the below steps

Reset the IIS

Then finally it will show your apps